Import Documentation

Developer
Mar 22, 2010 at 12:26 PM

Hi,

 

I've revised the documentation for the importing of projects - r42449.

 

Any thoughts/comments/suggestions on the changes?

 

Thanks!

Developer
Mar 22, 2010 at 12:42 PM
On Mon, Mar 22, 2010 at 7:26 AM, [email removed] wrote:

> I've revised the documentation for the importing of projects - r42449.
>
> Any thoughts/comments/suggestions on the changes?

It's pretty hard to review commits... can you publish the snapshot
docs so we can take a look?

--
Wendy
Developer
Mar 24, 2010 at 3:10 AM

maven version: 2.1.1
subversion: 1.5.1

* added the following lines to settings.xml

    <server>
      <username>username</username>
      <password>password</password>
      <id>npanday.site</id>
    </server>
    
* added the configuration of [auto-prop] in http://www.apache.org/dev/svn-eol-style.txt to C:\Documents and Settings\{user}\Application Data\Subversion\config
* run 'mvn clean install' against trunk
* run 'mvn clean site' against trunk\site
* run 'mvn site-deploy -DrepositoryId=npanday.site' against trunk\site and got this error:


[INFO] Working directory: C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout
 Transfer error: org.apache.maven.scm.ScmException: Unable to commit file. The svn command failed. svn: Commit failed (details follow):
svn: While preparing 'C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout\images\vs\settings_location.jpg' for commit
svn: Inconsistent line ending style

scm:svn:https://npanday.svn.codeplex.com/svn/docs/1.2-SNAPSHOT - Session: Disconnecting
scm:svn:https://npanday.svn.codeplex.com/svn/docs/1.2-SNAPSHOT - Session: Disconnected
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error uploading site

Embedded error: Error interacting with SCM: Unable to commit file. The svn command failed. svn: Commit failed (details follow):
svn: While preparing 'C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout\images\vs\settings_location.jpg' for commit
svn: Inconsistent line ending style



I tried adding a new property for the image (svn:eol-style) and set it to native but got a warning that the file already has a binary mime type property.


Any thoughts or suggestions?


Thanks!

Developer
Mar 27, 2010 at 1:36 PM
On Tue, Mar 23, 2010 at 10:10 PM, apadilla <notifications@codeplex.com> wrote:

> Embedded error: Error interacting with SCM: Unable to commit file. The svn
> command failed. svn: Commit failed (details follow):
> svn: While preparing
> 'C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout\images\vs\settings_location.jpg'
> for commit
> svn: Inconsistent line ending style
>
> I tried adding a new property for the image (svn:eol-style) and set it to
> native but got a warning that the file already has a binary mime type
> property.

No idea -- I can't even get it to update cleanly. After getting
distracted with that a few times, I finally built the site locally and
tracked down which page you edited in that commit. You're asking
about this text, right?

"The SCM Tag is optional. Adding a scm url that is either an
unresolvable location or returns some other error (e.g: it is
authenticated and the credentials are not supplied or incorrect) will
still be generated in the project's parent pom."

Does the code still try to open/load the scm url? Is there a warning
of some kind if the url is not reachable?

(If you're going to use whatever url they supply regardless of whether
it's reachable by the Addin, I don't see the point of checking it.)

The text implies that there is some way to provide credentials for the
svn url... is that really true?

My suggestion is: "The scm tag is optional. If you provide a url
that is not reachable by the Addin, you will see a warning, but the
url will still be added to the parent pom.

(Or remove the bit about the warning if that doesn't happen.)

--
Wendy
Developer
Mar 30, 2010 at 3:02 AM

Hi Wendy,

 

Thanks for your inputs.  There's a warning message that'll pop up when the url provided is unreachable.

 

I've revised the docs with the ff:

 

The <SCM Tag> is optional.  If you provide a url that is not reachable (e.g: it is authenticated and the credentials are not supplied or incorrect) by the Addin,
  you will see a warning, but the url will still be added to the parent pom.

 

Thanks!

Coordinator
Apr 14, 2010 at 3:13 PM
apadilla wrote:

maven version: 2.1.1
subversion: 1.5.1

* added the following lines to settings.xml

    <server>
      <username>username</username>
      <password>password</password>
      <id>npanday.site</id>
    </server>
    
* added the configuration of [auto-prop] in http://www.apache.org/dev/svn-eol-style.txt to C:\Documents and Settings\{user}\Application Data\Subversion\config
* run 'mvn clean install' against trunk
* run 'mvn clean site' against trunk\site
* run 'mvn site-deploy -DrepositoryId=npanday.site' against trunk\site and got this error:


[INFO] Working directory: C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout
 Transfer error: org.apache.maven.scm.ScmException: Unable to commit file. The svn command failed. svn: Commit failed (details follow):
svn: While preparing 'C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout\images\vs\settings_location.jpg' for commit
svn: Inconsistent line ending style

scm:svn:https://npanday.svn.codeplex.com/svn/docs/1.2-SNAPSHOT - Session: Disconnecting
scm:svn:https://npanday.svn.codeplex.com/svn/docs/1.2-SNAPSHOT - Session: Disconnected
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error uploading site

Embedded error: Error interacting with SCM: Unable to commit file. The svn command failed. svn: Commit failed (details follow):
svn: While preparing 'C:\DOCUME~1\liit\LOCALS~1\Temp\wagon-scm142785281.checkout\images\vs\settings_location.jpg' for commit
svn: Inconsistent line ending style



I tried adding a new property for the image (svn:eol-style) and set it to native but got a warning that the file already has a binary mime type property.


Any thoughts or suggestions?


Thanks!

I'm not sure how it happened, but the checkin I did before set an eol-style on those images. I removed them and redeployed to SVN, so it should be fine now.