NPanday 1.2-RC2 now ready for testing

Developer
Jun 2, 2010 at 10:54 AM

Hi,


With the help of Brett, Deng and Joe, I was able to successfully release NPanday 1.2-RC2 which is built here:


http://repo.npanday.org/archiva/repository/npanday-releases/npanday/npanday-repository-builder/1.2-RC2/

tag: https://npanday.svn.codeplex.com/svn/releases/npanday-project-RC2/
installer: http://repo.npanday.org/archiva/repository/npanday-releases/npanday/npanday-installer/1.2-RC2/


Btw, I did the release through the command line because there are issues when releasing in the CI as discussed here:

http://npanday.codeplex.com/Thread/View.aspx?ThreadId=213498


I will be posting another discussion on my proposal for the release (through the command line).


This is now ready for testing and if there are no major flaws, we will be pushing through with the release of 1.2 on Friday, June 4, 2010.


Thanks,

liit

Coordinator
Jun 2, 2010 at 5:18 PM

Thanks Liit for all the effort you put into this release!

 

I think we could live with releasing for the command line at the moment and we could just document the new release process and the errors that you encountered so that we will have a smoother release next time.

 

Thanks again Liit :D

I will be testing the 1.2-RC2 now

Developer
Jun 3, 2010 at 8:17 AM

Hi Liit, thanks for releasing 1.2-RC2! :-)

I tried installing NPanday using the msi file and 'twas successful. I got the projects built successfully in command prompt. However, when building the projects in VS, it is stuck! Also (new behavior), repository, uac and gac are generated when/after building the 1st project successfully.

Developer
Jun 3, 2010 at 1:12 PM

Hi All,


I also unpacked npanday-repository-builder and was not able to successfully run the vsinstaller command 'mvn npanday.plugin:maven-vsinstaller-plugin:install' but instead got this error -> http://pastie.org/990357

I checked out the tag then run 'mvn clean install' then, 'mvn npanday.plugin:maven-vsinstaller-plugin:install' after.

The addins were successfully generated in the "C:\Documents and Settings\{user}\My Documents\Visual Studio 2005\Addins" and "C:\Documents and Settings\{user}\My Documents\Visual Studio 2008\Addins" folders respectively.


I am to build fine a project in the command line but when starting NPanday in VS (Tools > NPanday Build System), I got this pop-up error message:


"The Add-in supporting this command could not be loaded. Do you wish to remove the command? If you choose yes, you can re-create the command by reinstalling the Add-in."


I will investigate further into the vsinstaller plugin and the mapping of dependencies as well.


Thanks,

liit

Developer
Jun 4, 2010 at 6:41 AM

Hi Liit,

With "Also (new behavior), repository, uac and gac are generated when/after building the 1st project successfully." Sorry, it is not a new behavior.

When installing NPanday using msi file, the installer did not respect the settings.xml in my .m2, instead it created another folder ( liit/.m2/ ). When building projects in command line after installing NPanday, that's the time it respects my settings.xml. This might be the cause of the problem building project in VS?

Jun 4, 2010 at 6:49 AM
Is it possible that something from Liit's environment got included in the installer that's why the liit/.m2 directory is being created?
Jun 4, 2010 at 7:12 AM
The default Location path set in the installer was specific to Liit's environment (C:\Documents and Settings\liit\.m2\repository) that's why the directory was created during the installation of NPanday.
Jun 4, 2010 at 7:55 AM
I was able to successfully install NPanday using the installer but it seems it has the wrong NPanday. According to Joe and Liit, there should be a version info that should show up when starting the NPanday AddIn in VS but it didn't show up in my case. Also, there's no version specified in ..\AddIn\NPanday.VisualStudio.AddIn file..
Jun 4, 2010 at 8:59 AM

I got the same error as Liit if using the vsinstaller plugin  bundled in the npanday repository. It seems to be looking for the artifact with .library and not with .dll?

 

Jun 4, 2010 at 9:17 AM
Edited Jun 4, 2010 at 9:17 AM

Also the same error with vsinstaller

 

Developer
Jun 5, 2010 at 4:37 AM

Hi All,

 

The commits on r51765 - skip copy of non-dotnet-dependencies to PAB, caused the failure of the Add-in to start successfully in VS.  It is for the fix of this issue -> http://npanday.codeplex.com/workitem/13296.

 

I will be reverting the fix for this one in trunk and will do another release NPanday 1.2-RC3 tonight.

 

Thanks!

Developer
Jun 5, 2010 at 4:44 AM

 

Btw, Issue #13296 is not included in the issues that'll be fixed in the 1.2 release.