NPanday 1.2-RC1 does not work

Jun 3, 2010 at 9:28 AM

Hi,

I installed NPanday 1.2-RC2 from msi installer (http://repo.npanday.org/archiva/repository/npanday-releases/npanday/npanday-installer/1.2-RC2/) and put it's repository (downloded from here http://repo.npanday.org/archiva/repository/npanday-releases/npanday/npanday-repository-builder/1.2-RC2/) on my repository manager (just for case it needs something). When I try to compile my project (both from VS and command line) I obtain following error:

[INFO] [NPanday.Plugin.Settings.JavaBinding:generate-settings {execution: default-generate-settings}]
NPanday: Start Process = 03.06.2010 11:31:34
"parameterFile=C:\Users\ARTEMF~1.PW\AppData\Local\Temp\Plugin8901389532869179564.xml" "assemblyFile=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Settings\1.2-RC2__npanday.plugin\NPanday.Plugin.Settings.dll" "mojoName=NPanday.Plugin.Settings.SettingsGeneratorMojo" "startProcessAssembly=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Loader\1.2-RC2__npanday.plugin\NPanday.Plugin.Loader.exe"
[INFO]
[INFO] Unhandled Exception: System.TypeLoadException: The domain manager specified by the host could not be instantiated.
[INFO]    at System.AppDomain.CreateDomainManager(String domainManagerAssemblyName, String domainManagerTypeName)
[INFO]    at System.AppDomain.SetDomainManager(Evidence providedSecurityInfo, Evidence creatorsSecurityInfo, IntPtr parentSecurityDescriptor, Boolean publishAppDomain)
[INFO]    at System.AppDomain.SetDefaultDomainManager(String fullName, String[] manifestPaths, String[] activationData)
NPanday: End Process = 03.06.2010 11:31:38; exit code = -532459699
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] NPANDAY-xxx-000
Embedded error: NPANDAY-063-000: Execution Path = C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Runner\1.2-RC2__npanday.plugin, Command = [parameterFile=C:\Users\ARTEMF~1.PW\AppData\Local\Temp\Plugin8901389532869179564.xml, assemblyFile=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Settings\1.2-RC2__npanday.plugin\NPanday.Plugin.Settings.dll, mojoName=NPanday.Plugin.Settings.SettingsGeneratorMojo, startProcessAssembly=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Loader\1.2-RC2__npanday.plugin\NPanday.Plugin.Loader.exe]
NPANDAY-040-001: Could not execute: Command = CMD.EXE /X /C NPanday.Plugin.Runner.exe parameterFile=C:\Users\ARTEMF~1.PW\AppData\Local\Temp\Plugin8901389532869179564.xml assemblyFile=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Settings\1.2-RC2__npanday.plugin\NPanday.Plugin.Settings.dll mojoName=NPanday.Plugin.Settings.SettingsGeneratorMojo startProcessAssembly=C:\Users\artem.fedorenko.PW\.m2\pab\gac_msil\NPanday.Plugin.Loader\1.2-RC2__npanday.plugin\NPanday.Plugin.Loader.exe, Result = -532459699
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 9 seconds
[INFO] Finished at: Thu Jun 03 11:31:38 EEST 2010
[INFO] Final Memory: 13M/33M
[INFO] ------------------------------------------------------------------------
NPanday Execution Failed!, with exit code: 1

 

Looks like it does not "understand" long user names in Temp path.

Is there some workaround?

Jun 4, 2010 at 6:37 AM
Hi, Does it work for you in 1.1? Or did you encounter this is just in 1.2-RC2? Thanks, Deng
Jun 4, 2010 at 6:52 AM

It works in 1.1 only if I install 1.1 form distributed repository (from downloads page) and if during installation and executing tasks maven does not have access to public NPanday repositories online (http://repo.npanday.org/archiva/repository/npanday-group). If it has access (trough proxy in internal repository manager for example) version 1.1 downloads (why??) some plugins from 1.2-RC2 (I can see downloading from console) and produces the same error. That is if I use 1.1 distribution in total isolation from public repositories it works. If not I get the same error. NPanday 1.1 started to behave in such manner after release of 1.2-RC2. If you need the console output I can provide it. This error occurs both in VS and when running from command line.

All installations was performed on clean system (performed manual uninstall as it is written in the documentation).

Now I am using 1.1 and it works but still I do not "let" maven download something from NPanday public repos.

So the problem is actually only in some plugins of 1.2-RC2 but 1.1 is also influenced as it automatically updates them during execution (if it can).

Thanks, Artem

P.S. Anyway thanks for great work on porting Maven to .NET!