Remote repositories ....

Apr 4, 2009 at 10:13 PM
Hey everyone,

I am just checking in as I am coming across a few issues that I am wondering if it is a known issue or if I am doing something wrong.

http://someipaddress:8080/artifactory-2.0.1/libraries.NET-snapshots-local/

Ok I have a repository using a location as seen here:
This repository points to an Artifactory installation.

Artifactory serves this distribution management location for me automatically.

When I attempt to supply this as a remote repository url to npanday settings I keep getting the following error:
Sorry, but you have entered an invalid URL for the remote repository.

Or if i change the URL to 
http://someipaddress:8080/artifactory-2.0.1/

I am receiving the following error:
There was a problem with the provided URL.
Stack track: Illegal characters in path.

Any thoughts or ideas with this would be greatly appreciated.

Thanks

Joe
Developer
Apr 4, 2009 at 10:48 PM
On Sat, Apr 4, 2009 at 3:13 PM, [email removed] wrote:

> I am just checking in as I am coming across a few issues that I am wondering
> if it is a known issue or if I am doing something wrong.
> http://someipaddress:8080/artifactory-2.0.1/libraries.NET-snapshots-local/
...
> When I attempt to supply this as a remote repository url to npanday settings
> I keep getting the following error:
> Sorry, but you have entered an invalid URL for the remote repository.

If you mean adding it as a remote repo so you can use 'Add Maven Artifact'...
check the issue tracker, I think that feature might only work with
Archiva right now.

--
Wendy
Apr 5, 2009 at 2:51 PM
Wendy,

You are correct.
It appears that at the moment I can only communicate with the Artifactory repository if I use the mvn deploy command from cmd-line.

Is anyone currently looking into communicating with Artifactory as a remote repository (through the 'Add Maven Artifact ...' feature)?

Thanks

Joe