What versions of Visual Studio and .NET Framework does NPanday support?

Developer
Sep 25, 2009 at 3:05 PM

I was asked whether NPanday supports .NET 1.1 and a quick look over the site didn't turn up info on what versions are supported.  The installation page says you must have .NET 2.0, but I think that's for NPanday to execute.

I'm fairly sure the Addin only works with VS 2005 and VS 2008.

What versions of the .NET framework does the pom generator support? 

Wasn't there a command-line pom generator at one point?

What versions of the .NET framework can be built with Maven at the command line, (assuming you write your own poms if they can't be generated)?

Thanks,
--
Wendy

Coordinator
Sep 29, 2009 at 3:38 AM

Hi Wendy,

The project generator supports .NET 2.0 framework upto .NET 3.5 framework.

Yes there was a command-line pom generator that generates a standard solution project. I think there was no enough discussion for the removal of the plugin and we should bring that back. I will open an issue regarding this one.

If you built your own pom  NPanday can support .NET 1.1 provided by the backward compatibility of .NET 2.0 and same goes for .NET 3.5

Thanks,